Aller au contenu

NSUPDATE

Exécuter mise à jour DNS

Run DNS Update

En bref

Syntaxe minimale

NSUPDATE

Paramètres

  • BCHFILE Fichier d'entrée par lots Batch input file
  • DEBUG Afficher les informations de débogage Show debug information
  • KEYNAME Nom de clé Key name
  • KEYFILE Fichier de clés Key file
  • TIMEOUT Délai d'attente de mise à jour Update timeout
  • UDPRTYITV Délai d'attente UDP UDP timeout
  • UDPNBRRTY Nouvelle tentative UDP UDP retry
  • PROTOCOL Protocole réseau Network protocol
  • LOCALHOST Mode hôte local uniquement Local host only mode
  • TOSTMF Fichier de sortie Output file

Astuce : dans une session 5250, tapez NSUPDATE puis F4 pour l'invite de saisie, et F1 sur un paramètre pour son aide.

Aide IBM i de la commande

Texte du F1, IBM i 7.5 en français (bibliothèque QDNS)

Où s'exécute : Tous les environnements (*ALL)
Compatible multitâche : Sous conditions

La commande Exécuter une mise à jour DNS (RUNDNSUPD), ou son alias NSUPDATE, est utilisée pour soumettre des demandes de mise à jour dynamique à un serveur DNS (Domain Name System). Cela permet d'ajouter ou de supprimer des enregistrements de ressource dans une zone sans modifier manuellement le fichier de zone. Une seule demande de mise à jour peut contenir des demandes d'ajout ou de suppression de plusieurs enregistrements de ressource. The Run DNS Update (RUNDNSUPD) command, or its alias NSUPDATE, is used to submit Dynamic Updates requests to a Domain Name System (DNS) server. This allows resource records to be added or removed from a zone without manually editing the zone file. A single update request can contain requests to add or remove more than one resource record.

Les zones placées sous contrôle dynamique via RUNDNSUPD ou un serveur DHCP ne doivent pas être modifiées manuellement. Des modifications manuelles pourraient entrer en conflit avec les mises à jour dynamiques et entraîner une perte de données. Zones that are under dynamic control via RUNDNSUPD or a DHCP server should not be edited by hand. Manual edits could conflict with dynamic updates and cause data to be lost.

Les enregistrements de ressource ajoutés ou supprimés dynamiquement avec RUNDNSUPD doivent appartenir à la même zone. Les demandes sont envoyées au serveur maître de la zone. Celui-ci est identifié par la zone MNAME de l'enregistrement SOA de la zone. The resource records that are dynamically added or removed with RUNDNSUPD have to be in the same zone. Requests are sent to the zones master server. This is identified by the MNAME field of the zones SOA record.

Cet utilitaire sera exécuté en mode interactif si *NONE est indiqué pour le paramètre Fichier d'entrée par lots (BCHFILE). Pour exécuter cet utilitaire en mode non interactif, indiquez un nom de fichier pour le paramètre BCHFILE. This utility will be run in interactive mode if *NONE is specified for the Batch input file (BCHFILE) parameter. To run this utility in non-interactive mode, specify a file name for the BCHFILE parameter.

Restrictions:

  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du fichier d'entrée par lots. You must have execute (*X) authority to the directories in the path of the batch input file.
  • Vous devez posséder le droit de lecture (*R) sur le fichier d'entrée par lots. You must have read (*R) authority to the batch input file.
  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du fichier de clés. You must have execute (*X) authority to the directories in the path of the key file.
  • Vous devez posséder le droit de lecture (*R) sur le fichier de clés. You must have read (*R) authority to the key file.
  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du fichier de sortie. You must have execute (*X) authority to the directories in the path of the output file.
  • Vous devez posséder le droit d'écriture (*W) sur le fichier de sortie s'il existe déjà. You must have write (*W) authority to the output file if it already exists.
  • Vous devez posséder les droits de lecture, d'écriture et d'exécution (*RWX) sur le répertoire parent du fichier de sortie si celui-ci n'existe pas encore. You must have read, write and execute (*RWX) authority to the output file's parent directory if the output file does not already exist.

Paramètres

Mot-clé Description Valeurs possibles Remarques
BCHFILE Fichier d'entrée par lotsBatch input file Chemin d'accès, *NONE Facultatif, positionnel 1
DEBUG Afficher les informations de débogageShow debug information *NO, *YES Facultatif, positionnel 2
KEYNAME Nom de cléKey name Valeur caractère, *NONE Facultatif
KEYFILE Fichier de clésKey file Chemin d'accès, *NONE Facultatif
TIMEOUT Délai d'attente de mise à jourUpdate timeout 1-300, 300, *NOMAX Facultatif
UDPRTYITV Délai d'attente UDPUDP timeout 1-65535, 3, *CALC Facultatif
UDPNBRRTY Nouvelle tentative UDPUDP retry 0-100, 3 Facultatif
PROTOCOL Protocole réseauNetwork protocol *UDP, *TCP Facultatif
LOCALHOST Mode hôte local uniquementLocal host only mode *NO, *YES Facultatif
TOSTMF Fichier de sortieOutput file Chemin d'accès, *STDOUT Facultatif

Fichier d'entrée par lots (BCHFILE)Batch input file (BCHFILE)

Indique un fichier STREAM contenant toutes les commandes de mise à jour à utiliser comme entrée par lots. Specifies a stream file with all update commands to be used as batch input.

Chaque commande du fichier est fournie sur exactement une ligne d'entrée. Certaines commandes sont destinées à l'administration. Les autres sont soit des instructions de mise à jour, soit des vérifications de prérequis sur le contenu de la zone. Ces vérifications définissent des conditions selon lesquelles un nom ou un ensemble d'enregistrements de ressource (RRset) existe ou est absent de la zone. Ces conditions doivent être remplies pour que l'ensemble de la demande de mise à jour aboutisse. Les mises à jour seront rejetées si les tests des conditions préalables échouent. Each command in the file is supplied on exactly one line of input. Some commands are for administrative purposes. The others are either update instructions or prerequisite checks on the contents of the zone. These checks set conditions that some name or set of resource records (RRset) either exists or is absent from the zone. These conditions must be met if the entire update request is to succeed. Updates will be rejected if the tests for the prerequisite conditions fail.

Chaque demande de mise à jour se compose de zéro prérequis ou plus et de zéro mise à jour ou plus. Cela permet à une demande de mise à jour dûment authentifiée de se dérouler si certains enregistrements de ressource indiqués sont présents ou absents de la zone. Une ligne d'entrée vide (ou la commande send) provoque l'envoi des commandes accumulées au serveur de noms sous la forme d'une seule demande de mise à jour DNS dynamique. Every update request consists of zero or more prerequisites and zero or more updates. This allows a suitably authenticated update request to proceed if some specified resource records are present or missing from the zone. A blank input line (or the send command) causes the accumulated commands to be sent as one Dynamic DNS update request to the name server.

Les formats de commande sont les suivants. Les lignes du fichier commençant par un point-virgule sont considérées comme des commentaires et sont ignorées : The command formats are as follows. Lines in the file beginning with a semicolon are considered comments and are ignored:

server éservernameè ¬port|
local éaddressè ¬port|
zone ézonenameè
class éclassnameè
key énameè ésecretè
prereq nxdomain édomain-nameè
prereq yxdomain édomain-nameè
prereq nxrrset  édomain-nameè       ¬class| étypeè
prereq yxrrset  édomain-nameè       ¬class| étypeè
prereq yxrrset  édomain-nameè       ¬class| étypeè édata...è
update delete   édomain-nameè ¬ttl| ¬class| ¬type ¬data...||
update add      édomain-nameè éttlè ¬class| étypeè édata...è
show
send
answer
quit

Voir les exemples pour la description de ces commandes. See the examples for descriptions of these commands.

*NONE
Do not use a batch file. This will enter interactive mode. To return from interactive mode, you must enter the command 'quit'.

Remarque :Cette valeur n'est valide que si la commande est exécutée dans un travail interactif. Remarque :This value is only valid if the command is run in an interactive job.

chemin-d'accès
Indiquez le chemin d'accès d'un fichier STREAM à partir duquel l'entrée est lue. Vous devez posséder le droit de lecture (*R) sur ce fichier. Specify the path for a stream file from which input is read. You must have read (*R) authority to this file.

Afficher les informations de débogage (DEBUG)Show debug information (DEBUG)

Indique s'il faut ou non activer le mode de débogage. Lorsque le mode de débogage est activé, davantage d'informations sont affichées sur le paquet envoyé au serveur et sur la réponse obtenue. Specifies whether or not to turn debugging mode on. More information is displayed about the packet sent to the server and the resulting answer when debugging mode is on.

*NO
Désactivez les messages de débogage. Turn off debugging messages.
*YES
Activez les messages de débogage. Turn on debugging messages.

Nom de clé (KEYNAME)Key name (KEYNAME)

Indique une clé TSIG (Transaction Signature) servant à signer les requêtes DNS. Le seul algorithme de synthèse de message actuellement utilisé pour TSIG est HMAC-MD5, bien que d'autres puissent être ajoutés ultérieurement. La clé TSIG est une chaîne codée en base 64, généralement générée par la commande Générer une clé DNS (GENDNSKEY). Le serveur DNS interrogé doit être configuré avec la clé TSIG et l'algorithme utilisés, faute de quoi la transaction échouera. Voir la RFC 2845 pour TSIG. Specifies a Transaction Signature (TSIG) key to sign the DNS queries. The only message digest algorithm currently used for TSIG is HMAC-MD5, although others may be added later. The TSIG key is a base-64 encoded string, typically generated by the Generate DNS Key (GENDNSKEY) command. The DNS server that is queried needs to be configured with the TSIG key and algorithm that is being used or the transaction will fail. See RFC 2845 for TSIG.

*NONE
N'indiquez pas de nom de clé. Do not specify a key name.
valeur-caractère
Specify the Transaction Signature key. The format is 'name:key' where name is the key name, and key is the actual key as a base-64 encoded string. Example:

my-tsig-key:JNvcpnxysbJ2hsdOqQ5qrQ==

Le nom de clé est ici 'my-tsig-key' et la clé codée en base 64 est 'JNvcpnxysbJ2hsdOqQ5qrQ=='. The key name in this case is 'my-tsig-key' and the base-64 encoded key is 'JNvcpnxysbJ2hsdOqQ5qrQ=='.

Le serveur DNS interrogé doit inclure cette clé et cet algorithme dans sa configuration afin d'accepter cette clé TSIG provenant des clients. The DNS server being queried needs to include this key and algorithm in its configuration in order to accept this TSIG key from clients.

Fichier de clés (KEYFILE)Key file (KEYFILE)

Indique un fichier contenant une clé SIG(0) servant à authentifier les demandes de mise à jour DNS dynamique. Dans ce cas, la clé indiquée n'est pas une clé HMAC-MD5. SIG(0) utilise la cryptographie à clé publique. Pour utiliser une clé SIG(0), la clé publique doit être stockée dans un enregistrement KEY d'une zone servie par le serveur de noms. Voir la RFC 3535 et la RFC 2931 pour SIG(0). Specifies a file containing a SIG(0) key used to authenticate Dynamic DNS update requests. In this case, the key specified is not an HMAC-MD5 key. SIG(0) uses public key cryptography. To use a SIG(0) key, the public key must be stored in a KEY record in a zone served by the name server. See RFC 3535 and RFC 2931 for SIG(0).

Remarque :Si une valeur autre que *NONE est indiquée pour ce paramètre, n'indiquez pas de valeur pour le paramètre KEYNAME. Remarque :If a value other than *NONE is specified for this parameter, do not specify a value for the KEYNAME parameter.

*NONE
N'indiquez pas de fichier de clés. Do not specify a key file.
chemin-d'accès
Indiquez le chemin d'accès d'un fichier STREAM contenant les informations de clé. Par exemple, '/home/myprofile/my-key-file' peut être indiqué. Specify the path for a stream file containing key information. For example, '/home/myprofile/my-key-file' could be specified.

Délai d'attente de mise à jour (TIMEOUT)Update timeout (TIMEOUT)

Indique le temps maximal qu'une demande de mise à jour peut prendre avant d'être abandonnée. Specifies the maximum time an update request can take before it is aborted.

300
Le délai d'attente par défaut est de 300 secondes. The default timeout is 300 seconds.
*NOMAX
Le délai d'attente de la demande de mise à jour est désactivé. The update request timeout is disabled.
1-300
Indiquez une valeur de délai d'attente valide, en secondes. Specify a valid timeout value in seconds.

Délai d'attente UDP (UDPRTYITV)UDP timeout (UDPRTYITV)

Indique l'intervalle, en secondes, entre les nouvelles tentatives UDP. Specifies the interval, in seconds, between UDP retries.

3
Un intervalle de nouvelle tentative de 3 secondes est utilisé. A retry interval of 3 seconds is used.
*CALC
L'intervalle de nouvelle tentative est calculé par l'utilitaire à partir des valeurs indiquées pour le paramètre Délai d'attente de mise à jour (TIMEOUT) et le paramètre Nouvelles tentatives UDP (UDPNBRRTY). The retry interval is calculated by the utility based on the values specified for the Update timeout (TIMEOUT) parameter and the UDP retry (UDPNBRRTY) parameter.
1-65535
Indiquez le nombre de secondes à utiliser entre les nouvelles tentatives UDP. Specify the number of seconds to use between UDP retries.

Nouvelle tentative UDP (UDPNBRRTY)UDP retry (UDPNBRRTY)

Indique le nombre de nouvelles tentatives UDP. Specifies the number of UDP retries.

3
Trois nouvelles tentatives UDP seront effectuées. Three UDP retries will be used.
0-100
Indiquez le nombre de nouvelles tentatives UDP. Si zéro est indiqué, une seule demande de mise à jour sera effectuée. Specify the number of UDP retries. If zero is specified, only one update request will be made.

Protocole réseau (PROTOCOL)Network protocol (PROTOCOL)

Indique s'il faut utiliser TCP ou UDP lors de l'envoi des demandes au serveur. Specified whether to use TCP or UDP when sending requests to the server.

*UDP
Utilise UDP pour envoyer la requête. Toutefois, TCP est automatiquement sélectionné pour les requêtes qui l'exigent, telles que les demandes de transfert de zone (AXFR). Use UDP to send the query. However, TCP will be automatically selected for queries that require it, such as zone transfer (AXFR) requests.
*TCP
Utilise TCP pour envoyer la requête. Use TCP to send the query.

Mode hôte local uniquement (LOCALHOST)Local host only mode (LOCALHOST)

Indique s'il faut ou non se connecter à l'hôte local. Les connexions au serveur local utiliseront une clé TSIG (transaction signature) située dans /QIBM/UserData/OS400/DNS/_DYN/nnnnn/session.key (nnnnn est le nom de l'instance DNS), qui est générée automatiquement par un serveur DNS si une zone maître locale a défini update-policy sur local. L'emplacement de ce fichier de clés peut être remplacé par le paramètre Fichier de clés (KEYFILE). Pour activer le mode hôte local uniquement, l'instance DNS nnnnn doit déjà être à l'écoute sur localhost (127.0.0.1). Specifies whether or not to connect to local host. Connections to the local server will use a transaction signature (TSIG) key found in /QIBM/UserData/OS400/DNS/_DYN/nnnnn/session.key (nnnnn is DNS instance name), which is automatically generated by a DNS server if any local master zone has set update-policy to local. The location of this key file can be overridden with the Key file (KEYFILE) parameter. To enable local host only mode, the DNS instance nnnnn must listen on the localhost(127.0.0.1) already.

*NO
Ne pas s'exécuter en mode hôte local uniquement. Do not run in local host only mode.
*YES
S'exécuter en mode hôte local uniquement. Run in local host only mode.

Fichier de sortie (TOSTMF)Output file (TOSTMF)

Indique le nom d'un fichier STREAM dans lequel toute la sortie de la commande est écrite. Specifies the name of a stream file where all command output is written.

*STDOUT
Toute la sortie de la commande est dirigée vers l'unité de sortie standard (normalement l'écran). All command output goes to the standard output device (normally the display).
chemin-d'accès
Indiquez le chemin d'accès d'un fichier STREAM dans lequel la sortie doit être écrite. Specify the path name for a stream file where output should be written.

Exemples

Les formats de commande et leur signification sont les suivants : The command formats and their meaning are as follows:

server éservernameè ¬port|
Envoie toutes les demandes de mise à jour dynamique au serveur DNS servername. Lorsqu'aucune instruction server n'est fournie, RUNDNSUPD envoie les mises à jour au serveur maître de la zone concernée. La zone MNAME de l'enregistrement SOA de cette zone identifie le serveur maître de cette zone. port est le numéro de port sur servername auquel les demandes de mise à jour dynamique sont envoyées. Si aucun numéro de port n'est indiqué, le numéro de port DNS par défaut, 53, est utilisé. Sends all dynamic update requests to the DNS server servername. When no server statement is provided, RUNDNSUPD will send updates to the master server of the correct zone. The MNAME field of that zones SOA record will identify the master server for that zone. port is the port number on servername where the dynamic update requests get sent. If no port number is specified, the default DNS port number of 53 is used.
local éaddressè ¬port|
Envoie toutes les demandes de mise à jour dynamique en utilisant l'adresse locale. Lorsqu'aucune instruction local n'est fournie, RUNDNSUPD envoie les mises à jour en utilisant une adresse et un port choisis par le système. port peut en outre servir à faire provenir les demandes d'un port précis. Si aucun numéro de port n'est indiqué, le système en attribue un. Sends all dynamic update requests using the local address. When no local statement is provided, RUNDNSUPD will send updates using an address and port chosen by the system. port can additionally be used to make requests come from a specific port. If no port number is specified, the system will assign one.
zone ézonenameè
Indique que toutes les mises à jour doivent être effectuées dans la zone zonename. Si aucune instruction zone n'est fournie, RUNDNSUPD tente de déterminer la zone à mettre à jour d'après le reste de l'entrée. Specifies that all updates are to be made to the zone zonename. If no zone statement is provided, RUNDNSUPD will attempt determine the correct zone to update based on the rest of the input.
class éclassnameè
Indiquez la classe par défaut. Si aucune classe n'est indiquée, la classe par défaut est IN. Specify the default class. If no class is specified the default class is IN.
key énameè ésecretè
Indique que toutes les mises à jour doivent être signées TSIG à l'aide de la paire keyname keysecret. La commande key remplace toute clé indiquée sur la ligne de commande via -y ou -k. Specifies that all updates are to be TSIG signed using the keyname keysecret pair. The key command overrides any key specified on the command line via -y or -k.
prereq nxdomain édomain-nameè
Exige qu'aucun enregistrement de ressource, quel que soit son type, n'existe avec le nom domain-name. Requires that no resource record of any type exists with name domain-name.
prereq yxdomain édomain-nameè
Exige que domain-name existe (possède au moins un enregistrement de ressource, de n'importe quel type). Requires that domain-name exists (has as at least one resource record, of any type).
prereq nxrrset édomain-nameè ¬class| étypeè
Exige qu'aucun enregistrement de ressource n'existe pour le type, la classe et le domain-name indiqués. Si class est omis, IN (Internet) est supposé. Requires that no resource record exists of the specified type, class and domain-name. If class is omitted, IN (internet) is assumed.
prereq yxrrset édomain-nameè ¬class| étypeè
Exige qu'un enregistrement de ressource du type, de la classe et du domain-name indiqués existe. Si class est omis, IN (Internet) est supposé. This requires that a resource record of the specified type, class and domain-name must exist. If class is omitted, IN (internet) is assumed.
prereq yxrrset édomain-nameè ¬class| étypeè édata...è
Les données de chaque ensemble de prérequis de cette forme partageant un même type, une même classe et un même domain-name sont combinées pour former un ensemble d'enregistrements de ressource. Cet ensemble d'enregistrements de ressource doit correspondre exactement à l'ensemble d'enregistrements de ressource existant dans la zone pour le type, la classe et le domain-name donnés. Les données sont écrites dans la représentation textuelle standard des RDATA des enregistrements de ressource. The data from each set of prerequisites of this form sharing a common type, class, and domain-name are combined to form a set of RRs. This set of RRs must exactly match the set of RRs existing in the zone at the given type, class, and domain-name. The data are written in the standard text representation of the resource records RDATA.
update delete édomain-nameè ¬ttl| ¬class| ¬type ¬data...||
Supprime tous les enregistrements de ressource nommés domain-name. Si type et data sont fournis, seuls les enregistrements de ressource correspondants sont supprimés. La classe Internet est supposée si class n'est pas fournie. Le ttl est ignoré et n'est autorisé que pour des raisons de compatibilité. Deletes any resource records named domain-name. If type and data is provided, only matching resource records will be removed. The internet class is assumed if class is not supplied. The ttl is ignored, and is only allowed for compatibility.
update add édomain-nameè éttlè ¬class| étypeè édata...è
Ajoute un nouvel enregistrement de ressource avec les ttl, class et data indiqués. Adds a new resource record with the specified ttl, class and data.
show
Affiche le message en cours, contenant tous les prérequis et toutes les mises à jour indiqués depuis le dernier envoi (send). Displays the current message, containing all of the prerequisites and updates specified since the last send.
send
Envoie le message en cours. Cela équivaut à saisir une ligne vide. Sends the current message. This is equivalent to entering a blank line.
answer
Affiche la réponse. Displays the answer.
quit
Quitte le mode interactif. Exit interactive mode.

Exemple 1 : Exemple de mise à jour Example 1: Update Example

RUNDNSUPD   BCHFILE(*NONE)
> update delete oldhost.example.com A
> update add newhost.example.com 86400 A 172.16.1.1
> send
> quit

Cette commande démarre le mode interactif de l'utilitaire de mise à jour. Les lignes qui ont le préfixe '>' sont des commandes interactives. This command will start the interactive mode for the update utility. The lines that have the '>' prefix are interactive commands.

Insère et supprime des enregistrements de ressource dans la zone 'example.com'. Notez que l'entrée de chaque exemple contient une ligne vide finale afin qu'un groupe de commandes soit envoyé sous la forme d'une seule demande de mise à jour dynamique au serveur DNS maître de example.com. Insert and delete resource records from the 'example.com' zone. Notice that the input in each example contains a trailing blank line so that a group of commands are sent as one dynamic update request to the master DNS server for example.com.

Tous les enregistrements A de oldhost.example.com sont supprimés et un enregistrement A pour newhost.example.com avec l'adresse IP 172.16.1.1 est ajouté. L'enregistrement nouvellement ajouté a une durée de vie (TTL) de 1 jour (86400 secondes) Any A records for oldhost.example.com are deleted and an A record for newhost.example.com with IP address 172.16.1.1 is added. The newly-added record has a 1 day TTL (86400 seconds)

Exemple 2 : Exemple de prérequis Example 2: Pre-requisite Example

RUNDNSUPD
> prereq nxdomain nickname.example.com
> update add nickname.example.com 86400 CNAME somehost.example.com
> send
> quit

La condition préalable demande au serveur DNS de vérifier qu'il n'existe aucun enregistrement de ressource, de quelque type que ce soit, pour nickname.example.com. S'il en existe, la demande de mise à jour échoue. Si ce nom n'existe pas, un CNAME est ajouté pour celui-ci. Cela garantit que, lorsque le CNAME est ajouté, il ne peut pas entrer en conflit avec la règle de longue date de la RFC1034 selon laquelle un nom ne doit pas exister sous un autre type d'enregistrement s'il existe sous forme de CNAME. (La règle a été mise à jour pour DNSSEC dans la RFC2535 afin de permettre aux CNAME d'avoir des enregistrements RRSIG, DNSKEY et NSEC.) The prerequisite condition gets the DNS server to check that there are no resource records of any type for nickname.example.com. If there are, the update request fails. If this name does not exist, a CNAME for it is added. This ensures that when the CNAME is added, it cannot conflict with the long-standing rule in RFC1034 that a name must not exist as any other record type if it exists as a CNAME. (The rule has been updated for DNSSEC in RFC2535 to allow CNAMEs to have RRSIG, DNSKEY and NSEC records.)

Exemple 3 : Exemple de fichier de traitement par lots Example 3: Batch File Example

RUNDNSUPD   BCHFILE('/home/ibmuser/my-updates')

Cette commande envoie les mises à jour du fichier '/home/ibmuser/my-updates' au serveur défini dans la commande server du fichier. Par exemple, le contenu du fichier peut ressembler à ceci : This command sends the updates in the file '/home/ibmuser/my-updates' to the server defined in the files server command. For example, the contents of the file might look like this:

server myserver.i5os.ibm.com 53
zone i5os.ibm.com
class in
prereq yxdomain box1.i5os.ibm.com.
update delete box1.i5os.ibm.com. A
update add box1.i5os.ibm.com. 3600 A 10.9.9.9
prereq yxdomain box2.i5os.ibm.com.
update delete box2.i5os.ibm.com. A
update add box2.i5os.ibm.com. 3600 A 10.9.9.10

Et les résultats affichés à l'écran peuvent ressembler à ceci : And the results displayed on the screen might look like this:

; TSIG error with server: tsig indicates error
update failed: NOTAUTH(BADKEY)

Ou les résultats affichés à l'écran peuvent ressembler à ceci : Or the results displayed on the screen might look like this:

; TSIG error with server: tsig indicates error
update failed: REFUSED

Le premier exemple représente le cas où la clé du fichier n'est pas valide. Le second exemple représente le cas où le serveur n'autorise pas les mises à jour dynamiques de votre part. L'absence de sortie ou une sortie vide signifie uniquement que la mise à jour a réussi. The first example represent the case when the key in the file is not valid. The second example represents the case when the server is not allowing dynamic updates from you. No output or blank output only means the update was successful.

Messages d'erreur

Messages *ESCAPE *ESCAPE Messages

DNS0013
Erreur lors du traitement des paramètres de la commande. Error processing command parameters.
DNS0065
L'option 33 de i5/OS est requise mais n'est pas installée. Option 33 of i5/OS is required, but is not installed.
TCP7124
Le programme &1 de la bibliothèque &2, de type *PGM, s'est terminé anormalement. Program &1 in library &2 type *PGM ended abnormally.

© Copyright IBM Corp. Texte d'aide reproduit à des fins de formation.