Aller au contenu

GENDNSKEY

Générer clé DNS

Generate DNS Key

En bref

La commande Générer une clé DNS (GENDNSKEY) génère des clés pour DNSSEC (DNS sécurisé), telles que définies dans les RFC 2535 et RFC 4034. The Generate DNS Key (GENDNSKEY) command generates keys for DNSSEC (Secure DNS), as defined in RFC 2535 and RFC 4034.

GENDNSKEY se lit GEN (Générer) + DNSKEY. Sur IBM i, le nom d'une commande associe presque toujours un verbe et un objet.

Syntaxe minimale

GENDNSKEY KEYNAME(…)

Paramètres

  • KEYNAME Nom de clé Key name obligatoire
  • SUCCSORTO Nom de clé dont celle-ci est le successeur Key name to successor to
  • ALGORITHM Algorithme cryptographique Cryptographic algorithm
  • KEYSIZE Taille de clé Key size
  • KEYOWNTYPE Type de propriétaire de clé Key owner type
  • COMPMODE Mode de compatibilité Compatibility mode
  • CLASS Classe Class
  • KEYFLAG Indicateur de clé Key flag
  • DHGEN Générateur pour clé DH Generator for DH key
  • QUIETMODE Mode silencieux Quiet mode
  • STRENGTH Robustesse de clé Key strength
  • RRTYPE Type d'enregistrement de ressource Resource record type
  • USETYPE Type d'utilisation de clé Key use type
  • PUBDATE Date de publication Published date
  • ACTDATE Date d'activation Activated date
  • RVKDATE Date de révocation Revoked date
  • RTEDATE Date de retrait Retired date
  • DLTDATE Date de suppression Deleted date
  • LRGEXP Utiliser un grand exposant Use large exponent
  • KEYPCLNBR Numéro de protocole de clé Key protocol number
  • ENTROPYSRC Source d'entropie Entropy source
  • DBGLVL Niveau de débogage Debug level
  • TOSTMF Fichier de sortie Output file

Astuce : dans une session 5250, tapez GENDNSKEY puis F4 pour l'invite de saisie, et F1 sur un paramètre pour son aide.

Aide IBM i de la commande

Texte du F1, IBM i 7.5 en français (bibliothèque QDNS)

Où s'exécute : Tous les environnements (*ALL)
Compatible multitâche : Non

La commande Générer une clé DNS (GENDNSKEY) génère des clés pour DNSSEC (DNS sécurisé), telles que définies dans les RFC 2535 et RFC 4034. Elle peut également générer des clés destinées à TSIG (Transaction Signatures), telles que définies dans la RFC 2845, ou à TKEY (Transaction Key), telles que définies dans la RFC 2930. The Generate DNS Key (GENDNSKEY) command generates keys for DNSSEC (Secure DNS), as defined in RFC 2535 and RFC 4034. It can also generate keys for use with TSIG (Transaction Signatures) as defined in RFC 2845, or TKEY (Transaction Key) as defined in RFC 2930.

Par défaut, les fichiers générés sont stockés dans le répertoire /QIBM/UserData/OS400/DNS/_DYN By default, the generated files would be stored in the directory of /QIBM/UserData/OS400/DNS/_DYN

Restrictions:

  • Vous devez posséder le droit spécial *SECADM pour utiliser cette commande. You must have *SECADM special authority to use this command.
  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du fichier de source d'entropie. You must have execute (*X) authority to the directories in the path of the entropy source file.
  • Vous devez posséder le droit de lecture (*R) sur le fichier de source d'entropie. You must have read (*R) authority to the entropy source file.
  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du répertoire d'ensembles de clés. You must have execute (*X) authority to the directories in the path of the keyset directory.
  • Vous devez posséder le droit de lecture (*R) sur les fichiers du répertoire d'ensembles de clés. You must have read (*R) authority to the keyset directory files.
  • Vous devez posséder le droit d'exécution (*X) sur les répertoires du chemin d'accès du fichier de sortie. You must have execute (*X) authority to the directories in the path of the output file.
  • Vous devez posséder le droit d'écriture (*W) sur le fichier de sortie s'il existe déjà. You must have write (*W) authority to the output file if it already exists.
  • Vous devez posséder les droits de lecture, d'écriture et d'exécution (*RWX) sur le répertoire parent du fichier de sortie si celui-ci n'existe pas encore. You must have read, write and execute (*RWX) authority to the output file's parent directory if the output file does not already exist.

Paramètres

Mot-clé Description Valeurs possibles Remarques
KEYNAME Nom de cléKey name Valeur caractère Obligatoire, positionnel 1
SUCCSORTO Nom de clé dont celle-ci est le successeurKey name to successor to Valeur caractère, *NONE Facultatif, positionnel 2
ALGORITHM Algorithme cryptographiqueCryptographic algorithm *RSASHA1, *NSEC3RSASHA1, *NSEC3DSA, *RSAMD5, *RSASHA256, *RSASHA512, *DSA, *DH, *MD5, *SHA1, *SHA224, *SHA256, *SHA384, *SHA512 Facultatif, positionnel 3
KEYSIZE Taille de cléKey size Entier non signé, 1024 Facultatif, positionnel 4
KEYOWNTYPE Type de propriétaire de cléKey owner type *ZONE, *HOST, *ENTITY, *USER, *OTHER Facultatif
COMPMODE Mode de compatibilitéCompatibility mode *NO, *YES Facultatif
CLASS ClasseClass *IN, *CH, *HS Facultatif
KEYFLAG Indicateur de cléKey flag *NONE, *KSK, *REVOKE Facultatif
DHGEN Générateur pour clé DHGenerator for DH key *PRIME, 2, 5 Facultatif
QUIETMODE Mode silencieuxQuiet mode *NO, *YES Facultatif
STRENGTH Robustesse de cléKey strength 0-15, *NONE Facultatif
RRTYPE Type d'enregistrement de ressourceResource record type *DNSKEY, *KEY Facultatif
USETYPE Type d'utilisation de cléKey use type *AUTHCONF, *NOAUTHCONF, *NOAUTH, *NOCONF Facultatif
PUBDATE Date de publicationPublished date Valeur caractère, *NOW Facultatif
ACTDATE Date d'activationActivated date Valeur caractère, *NOW Facultatif
RVKDATE Date de révocationRevoked date Valeur caractère, *NONE Facultatif
RTEDATE Date de retraitRetired date Valeur caractère, *NONE Facultatif
DLTDATE Date de suppressionDeleted date Valeur caractère, *NONE Facultatif
LRGEXP Utiliser un grand exposantUse large exponent *NO, *YES Facultatif
KEYPCLNBR Numéro de protocole de cléKey protocol number 0-255, 3 Facultatif
ENTROPYSRC Source d'entropieEntropy source Chemin d'accès, *DFT Facultatif
DBGLVL Niveau de débogageDebug level 0-10, 0 Facultatif
TOSTMF Fichier de sortieOutput file Chemin d'accès, *STDOUT Facultatif

Nom de clé (KEYNAME)Key name (KEYNAME)

Indique le nom de clé à utiliser. Pour les clés DNSSEC, il doit correspondre au nom de la zone pour laquelle la clé est générée. Specifies the key name to use. For DNSSEC keys, this must match the name of the zone for which the key is being generated.

Ce paramètre est obligatoire. This is a required parameter.

valeur-caractère
Indiquez le nom de la clé à générer. Specify the name of the key to be generated.

Nom de clé dont celle-ci est le successeur (SUCCSORTO)Key name to successor to (SUCCSORTO)

Indique le nom de la clé existante dont la nouvelle clé est le successeur. La nouvelle clé créée en est un successeur explicite et son nom, son algorithme, sa taille et son type sont définis pour correspondre à ceux de la clé existante. La date d'activation de la nouvelle clé est définie sur la date de désactivation de la clé existante. La date de publication est définie sur la date d'activation moins l'intervalle de prépublication, qui est par défaut de 30 jours. Specifies the existing key name to successor to. The created new key is an explicit successor to it and the name, algorithm, size, and type of the key will be set to match it. The activation date of the new key will be set to the inactivation date of the existing one. The publication date will be set to the activation date minus the prepublication interval, which defaults to 30 days.

*NONE
N'indiquez pas de nom de clé dont celle-ci serait le successeur. Do not specify the existing successor to key name.
valeur-caractère
Indiquez un nom de clé valide de 255 caractères au maximum. Specify a valid key name up to 255 characters.

Algorithme cryptographique (ALGORITHM)Cryptographic algorithm (ALGORITHM)

Indique l'algorithme cryptographique à utiliser. Pour les clés DNSSEC, la valeur de l'algorithme doit être *RSAMD5, *RSASHA1, *DSA, *NSEC3RSASHA1, *NSEC3DSA, *RSASHA256 ou *RSASHA512. Pour TSIG/TKEY, la valeur doit être *DH (Diffie Hellman), *MD5, *SHA1, *SHA224, *SHA256, *SHA384 ou *SHA512. Specifies the cryptographic algorithm to use. For DNSSEC keys, the value of algorithm must be one of *RSAMD5, *RSASHA1, *DSA, *NSEC3RSASHA1, *NSEC3DSA, *RSASHA256 or *RSASHA512. For TSIG/TKEY, the value must be *DH (Diffie Hellman), *MD5, *SHA1, *SHA224, *SHA256, *SHA384, or *SHA512.

Remarque :Pour DNSSEC, il est recommandé de mettre en oeuvre les algorithmes *RSASHA1 et *DSA. Pour TSIG, *MD5 est recommandé. Remarque :For DNSSEC, *RSASHA1 and *DSA are recommended to implement algorithm. For TSIG, *MD5 is recommended.

Remarque :*DH, *MD5 et *SHA1 à *SHA512 impliquent automatiquement RRTYPE(*KEY). Remarque :*DH, *MD5, and *SHA1 through *SHA512 automatically imply RRTYPE(*KEY).

*RSASHA1
RSA est un algorithme de chiffrement à clé publique. Secure Hash Algorithm 1 (SHA1) est un algorithme de hachage à sens unique. RSA is an algorithm for public key encryption. Secure Hash Algorithm 1 (SHA1) is a one-way hash algorithm.
*NSEC3RSASHA1
Algorithme RSASHA1 compatible NSEC3. NSEC3-capable RSASHA1 algorithm.
*NSEC3DSA
Algorithme DSA compatible NSEC3. NSEC3-capable DSA algorithm.
*RSAMD5
RSA est un algorithme de chiffrement à clé publique. Message-Digest 5 (MD5) est un algorithme de hachage à sens unique. RSA is an algorithm for public key encryption. Message-Digest 5 (MD5) is a one-way hash algorithm.
*RSASHA256
RSA est un algorithme de chiffrement à clé publique. Secure Hash Algorithm 256 (SHA256) est un algorithme de hachage à sens unique. RSA is an algorithm for public key encryption. Secure Hash Algorithm 256 (SHA256) is a one-way hash algorithm.
*RSASHA512
RSA est un algorithme de chiffrement à clé publique. Secure Hash Algorithm 512 (SHA512) est un algorithme de hachage à sens unique. RSA is an algorithm for public key encryption. Secure Hash Algorithm 512 (SHA512) is a one-way hash algorithm.
*DSA
Algorithme de signature numérique (Digital Signature Algorithm). Digital Signature Algorithm.
*DH
Échange de clés Diffie-Hellman Diffie-Hellman key exchange
*MD5
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Message-Digest 5 (MD5). Keyed-hash message authentication code (HMAC) using Message-Digest 5 (MD5) hash algorithm.
*SHA1
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Secure Hash Algorithm (SHA-1). Keyed-hash message authentication code (HMAC) using Secure Hash Algorithm (SHA-1) hash algorithm.
*SHA224
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Secure Hash Algorithm (SHA-224). Keyed-hash message authentication code (HMAC) using Secure Hash Algorithm (SHA-224) hash algorithm.
*SHA256
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Secure Hash Algorithm (SHA-256). Keyed-hash message authentication code (HMAC) using Secure Hash Algorithm (SHA-256) hash algorithm.
*SHA384
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Secure Hash Algorithm (SHA-384). Keyed-hash message authentication code (HMAC) using Secure Hash Algorithm (SHA-384) hash algorithm.
*SHA512
Code d'authentification de message par clé de hachage (HMAC) utilisant l'algorithme de hachage Secure Hash Algorithm (SHA-512). Keyed-hash message authentication code (HMAC) using Secure Hash Algorithm (SHA-512) hash algorithm.

Taille de clé (KEYSIZE)Key size (KEYSIZE)

Indique le nombre de bits de la clé. Le choix de la taille de clé dépend de l'algorithme utilisé. Les clés RSA (*RSASHA1, *NSEC3RSASHA1, *RSAMD5, *RSASHA256) doivent comporter entre 512 et 4096 bits. Les clés RSA (*RSASHA512) doivent comporter entre 1024 et 4096 bits. Les clés Diffie Hellman (*DH) doivent comporter entre 128 et 4096 bits. Les clés DSA (*DSA, *NSEC3DSA) doivent comporter entre 512 et 1024 bits et être un multiple exact de 64. Les clés HMAC (*MD5, *SHA512) doivent comporter entre 1 et 512 bits. Les clés HMAC (*SHA1) doivent comporter entre 1 et 160 bits. Les clés HMAC (*SHA224) doivent comporter entre 1 et 224 bits. Les clés HMAC (*SHA256) doivent comporter entre 1 et 256 bits. Les clés HMAC (*SHA384) doivent comporter entre 1 et 384 bits. Specifies the number of bits in the key. The choice of key size depends on the algorithm used. RSA(*RSASHA1, *NSEC3RSASHA1, *RSAMD5, *RSASHA256) keys must be between 512 and 4096 bits. RSA(*RSASHA512) keys must be between 1024 and 4096 bits. Diffie Hellman(*DH) keys must be between 128 and 4096 bits. DSA(*DSA, *NSEC3DSA) keys must be between 512 and 1024 bits and an exact multiple of 64. HMAC(*MD5, *SHA512) keys must be between 1 and 512 bits. HMAC(*SHA1) keys must be between 1 and 160 bits. HMAC(*SHA224) keys must be between 1 and 224 bits. HMAC(*SHA256) keys must be between 1 and 256 bits. HMAC(*SHA384) keys must be between 1 and 384 bits.

Si un algorithme par défaut (*RSASHA1) est utilisé, la taille de clé recommandée est de 1024 bits pour les clés de signature de zone (ZSK) et de 2048 bits pour les clés de signature de clés (KSK, générées avec KEYFLAG(*KSK)). If using a default algorithm(*RSASHA1), the recommended key size is 1024 bits for zone signing keys (ZSK) and 2048 bits for key signing keys (KSK, generated with KEYFLAG(*KSK)).

1024
Le nombre de bits sera de 1024. The number of bits will be 1024.
1-4096
Indiquez le nombre de bits de la clé. Specify the number of bits for the key.

Type de propriétaire de clé (KEYOWNTYPE)Key owner type (KEYOWNTYPE)

Indique le type de propriétaire de la clé. Specifies the owner type of the key.

*ZONE
Pour les clés de zone DNSSEC (KEY/DNSKEY). For DNSSEC zone keys (KEY/DNSKEY).
*HOST
Pour une clé associée à un hôte (KEY). For a key associated with a host (KEY).
*ENTITY
Pour une clé associée à une entité (KEY). For a key associated with a entity (KEY).
*USER
Clé associée à un utilisateur (KEY). A key associated with a user (KEY).
*OTHER
DNSKEY.

Mode de compatibilité (COMPMODE)Compatibility mode (COMPMODE)

Indique s'il faut ou non générer une clé de style ancien, sans métadonnées. Par défaut, cette commande CL inclut la date de création de la clé dans les métadonnées stockées avec la clé privée, et d'autres dates peuvent également y être définies (date de publication, date d'activation, etc.). Les clés qui incluent ces données peuvent être incompatibles avec les anciennes versions de BIND. Specifies whether or not to generate an old-style key, without any metadata. By default, this CL command will include the key's creation date in the metadata stored with the private key, and other dates may be set there as well (publication date, activation date, etc). Keys that include this data may be incompatible with older versions of BIND.

*NO
Ne générez pas de clé de style ancien. Do not generate an old-style key.
*YES
Générez une clé de style ancien. Generate an old-style key.

Classe (CLASS)Class (CLASS)

Indique le groupe de protocoles des informations. Specifies the protocol group of the information.

*IN
La classe Internet. The Internet class.
*CH
La classe CHAOS. The CHAOS class.
*HS
La classe Hesiod. The Hesiod class.

Indicateur de clé (KEYFLAG)Key flag (KEYFLAG)

Indique l'indicateur à définir dans la zone d'indicateurs de l'enregistrement KEY/DNSKEY. Les seuls indicateurs reconnus sont KSK (Key Signing Key) et REVOKE. Specifies the flag to set in the flag field of the KEY/DNSKEY record. The only recognized flags are KSK (Key Signing Key) and REVOKE.

*NONE
Ne définissez aucun indicateur. Do not set any flags.
*KSK
Définissez l'indicateur KSK. Set the KSK flag.
*REVOKE
Définissez l'indicateur REVOKE. Set the REVOKE flag.

Générateur pour clé DH (DHGEN)Generator for DH key (DHGEN)

Indique, en cas de génération d'une clé Diffie-Hellman, la valeur du générateur à utiliser. Specifies, if generating a Diffie-Hellman key, the generator value to use.

*PRIME
Une valeur première sera sélectionnée conformément à la RFC 2539, si possible. Sinon, la valeur 2 est utilisée. A prime value will be selected based on RFC 2539, if possible. Otherwise, a value of 2 is used.
2
La valeur 2 sera utilisée. A value of 2 will be used.
5
La valeur 5 sera utilisée. A value of 5 will be used.

Mode silencieux (QUIETMODE)Quiet mode (QUIETMODE)

Indique s'il faut ou non supprimer les sorties inutiles, y compris l'indication de progression. Specifies whether or not to suppress unnecessary output, including progress indication.

Sans cette option, lorsque cette commande CL est exécutée de manière interactive pour générer une paire de clés RSA ou DSA, elle imprime sur stderr une chaîne de symboles indiquant la progression de la génération de clé. Without this option, when this CL command is run interactively to generate an RSA or DSA key pair, it will print a string of symbols to stderr indicating the progress of the key generation.

*NO
Ne supprime pas les sorties inutiles. Do not suppresses unnecessary output.
*YES
Supprime les sorties inutiles. Suppresses unnecessary output.

Robustesse de clé (STRENGTH)Key strength (STRENGTH)

Indique la valeur de robustesse de la clé. La robustesse est un nombre compris entre 0 et 15 et n'a actuellement aucune utilité définie dans DNSSEC. Specifies the strength value of the key. The strength is a number between 0 and 15, and currently has no defined purpose in DNSSEC.

*NONE
N'indiquez pas de valeur de robustesse. Not specify one strength value.
0-15
Indiquez une valeur de robustesse valide. Specify a valid strength value.

Type d'enregistrement de ressource (RRTYPE)Resource record type (RRTYPE)

Indique si des enregistrements de ressource (RR) KEY doivent être générés plutôt que des RR DNSKEY. Specifies if KEY resource records (RRs) rather than DNSKEY RRs should be generated.

*DNSKEY
Des enregistrements de ressource DNSKEY seront créés. DNSKEY resource records will be created.
*KEY
Des enregistrements de ressource KEY seront créés. KEY resource records will be created.

Type d'utilisation de clé (USETYPE)Key use type (USETYPE)

Indique comment la clé sera utilisée. AUTH désigne la capacité d'authentifier des données et CONF la capacité de chiffrer des données. Specifies how the key will be used. AUTH refers to the ability to authenticate data and CONF refers to the ability to encrypt data.

*AUTHCONF
Authentification et chiffrement des données. Authentication and data encryption.
*NOAUTHCONF
Ni authentification ni chiffrement des données. Neither authentication nor data encryption.
*NOAUTH
Chiffrement des données uniquement. Data encryption only.
*NOCONF
Authentification uniquement. Authentication only.

Date de publication (PUBDATE)Published date (PUBDATE)

Indique la date à laquelle une clé doit être publiée dans la zone. Après cette date, la clé sera incluse dans la zone mais ne sera pas utilisée pour la signer. Specifies the date on which a key is to be published to the zone. After that date, the key will be included in the zone but will not be used to sign it.

*NOW
La date de publication par défaut est la date du jour. The default published date is the current date.
YYYYMMDDHHMMSS
Indique la date (en UTC) à laquelle une clé doit être publiée dans la zone. Specifies the date(in UTC) on which a key is to be published to the zone.

Date d'activation (ACTDATE)Activated date (ACTDATE)

Indique la date à laquelle une clé doit être activée. Après cette date, la clé sera incluse dans la zone et utilisée pour la signer. Specifies the date on which a key is to be activated. After that date, the key will be included in the zone and used to sign it.

*NOW
La date d'activation par défaut est la date du jour. The default activated date is the current date.
YYYYMMDDHHMMSS
Indique la date (en UTC) à laquelle une clé doit être activée. Specifies the date(in UTC) on which a key is to be activated.

Date de révocation (RVKDATE)Revoked date (RVKDATE)

Indique la date à laquelle une clé doit être révoquée. Après cette date, la clé sera signalée comme révoquée. Elle sera incluse dans la zone et sera utilisée pour la signer. Specifies the date on which a key is to be revoked. After that date, the key will be flagged as revoked. It will be included in the zone and will be used to sign it.

*NONE
N'indiquez pas de date de révocation. Do not specify the revoked date.
YYYYMMDDHHMMSS
Indique la date (en UTC) à laquelle une clé doit être révoquée. Specifies the date(in UTC) on which a key is to be revoked.

Date de retrait (RTEDATE)Retired date (RTEDATE)

Indique la date à laquelle une clé doit être retirée. Après cette date, la clé sera toujours incluse dans la zone, mais ne sera plus utilisée pour la signer. Specifies the date on which a key is to be retired. After that date, the key will still be included in the zone, but it will not be used to sign it.

*NONE
N'indiquez pas de date de retrait. Do not specify the retired date.
YYYYMMDDHHMMSS
Indique la date (en UTC) à laquelle une clé doit être retirée. Specifies the date(in UTC) on which a key is to be retired.

Date de suppression (DLTDATE)Deleted date (DLTDATE)

Indique la date à laquelle une clé doit être supprimée. Après cette date, la clé ne sera plus incluse dans la zone. (Elle peut cependant rester dans le référentiel de clés.) Specifies the date on which a key is to be deleted. After that date, the key will no longer be included in the zone. (It may remain in the key repository, however.)

*NONE
N'indiquez pas de date de suppression. Do not specify the deleted date.
YYYYMMDDHHMMSS
Indique la date (en UTC) à laquelle une clé doit être supprimée. Specifies the date(in UTC) on which a key is to be deleted.

Utiliser un grand exposant (LRGEXP)Use large exponent (LRGEXP)

Indique, en cas de génération d'une clé RSA (RSAMD5/RSASHA1/ RSASHA256/NSEC3RSASHA1/RSASHA512), s'il faut ou non utiliser un grand exposant. Specifies, if generating an RSA(RSAMD5/RSASHA1/ RSASHA256/NSEC3RSASHA1/RSASHA512) key, whether or not to use a large exponent.

*NO
N'utilisez pas de grand exposant. Do not use a large exponent.
*YES
Utilisez un grand exposant. Use a large exponent.

Numéro de protocole de clé (KEYPCLNBR)Key protocol number (KEYPCLNBR)

Indique la valeur de protocole de la clé générée. Le protocole est un nombre compris entre 0 et 255. La valeur par défaut livrée est 3 (DNSSEC). D'autres valeurs possibles pour cet argument sont répertoriées dans la RFC 2535 et ses successeurs. Specifies the protocol value for the generated key. The protocol is a number between 0 and 255. The shipped default value is 3 (DNSSEC). Other possible values for this argument are listed in RFC 2535 and its successors.

3
La valeur de protocole sera 3. The protocol value will be 3.
0-255
Indiquez une valeur de protocole de clé valide. Specify a valid key protocol value.

Source d'entropie (ENTROPYSRC)Entropy source (ENTROPYSRC)

Indique une source de données aléatoires pour générer l'autorisation. Si, pour une raison quelconque, le fichier d'entropie par défaut n'est pas assez volumineux, ce paramètre vous permet de remplacer la source d'entropie par une source plus importante. Specifies a source of random data for generating the authorization. If for some reason the default entropy file is not large enough, this parameter allows you to change the entropy source to one that is larger.

*DFT
La source d'entropie aléatoire par défaut /dev/urandom sera utilisée. The default entropy source of randomness /dev/urandom will be used.
chemin-d'accès
Indiquez le chemin d'accès d'un fichier STREAM devant servir de source d'entropie. Specify the path for a stream file to serve as an entropy source.

Niveau de débogage (DBGLVL)Debug level (DBGLVL)

Indique le niveau de débogage, qui détermine la quantité d'informations de diagnostic (débogage) générées par cette commande. Specifies the debugging level to indicate how much diagnostic (debug) information this command will generate.

0
Le débogage est désactivé. Debugging is off.
1-10
Indiquez un nombre compris entre 1 et 10. La quantité d'informations de débogage augmente avec la valeur de DBGLVL. La valeur 1 correspond au minimum d'informations de débogage, la valeur 10 au maximum. Specify a number within the range of 1-10. The amount of debug information increases as the DBGLVL value increases. 1 equals minimum debug information. 10 equals maximum debug information.

Fichier de sortie (TOSTMF)Output file (TOSTMF)

Indique le nom d'un fichier STREAM dans lequel toute la sortie de la commande est écrite. Specifies the name of a stream file where all command output is written.

*STDOUT
Toute la sortie de la commande est dirigée vers l'unité de sortie standard (normalement l'écran). All command output goes to the standard output device (normally the display).
chemin-d'accès
Indiquez le chemin d'accès d'un fichier STREAM dans lequel la sortie doit être écrite. Specify the path name for a stream file where output should be written.

Exemples

GENDNSKEY KEYNAME('my-tsig-key')
            ALGORITHM(*MD5)
            KEYSIZE(128)
            KEYOWNTYPE(*HOST)
            RRTYPE(*KEY)

Cette commande génère une clé nommée 'my-tsig-key' et les fichiers de clé sont placés dans le répertoire '/QIBM/UserData/OS400/DNS/_DYN'. Les noms des fichiers de clé sont affichés en sortie, par exemple : This command generates a key named 'my-tsig-key' and the key files are placed into directory '/QIBM/UserData/OS400/DNS/_DYN'. The name of the key files are displayed as output, for example:

/QIBM/UserData/OS400/DNS/_DYN/my-tsig-key._KEY (symlink)
/QIBM/UserData/OS400/DNS/_DYN/Kmy-tsig-key.+157+12836.key
/QIBM/UserData/OS400/DNS/_DYN/Kmy-tsig-key.+157+12836.private

Le contenu du fichier de clé '/QIBM/UserData/OS400/DNS/_DYN/my-tsig-key._KEY' peut ressembler à ceci : The contents of key file '/QIBM/UserData/OS400/DNS/_DYN/my-tsig-key._KEY' might look like this:

my-tsig-key. IN KEY 512 3 157 emjb8j5JDB7JFBqXCj5kkQ==

GENDNSKEY KEYNAME('example.com.')
            ALGORITHM(*RSASHA1)
            KEYSIZE(1024)
            KEYOWNTYPE(*ZONE)

Cette commande génère une clé nommée 'example.com.' et les fichiers de clé sont placés dans le répertoire '/QIBM/UserData/OS400/DNS/_DYN'. Les noms des fichiers de clé sont affichés en sortie, par exemple : This command generates a key named 'example.com.' and the key files are placed into directory '/QIBM/UserData/OS400/DNS/_DYN'. The name of the key files are displayed as output, for example:

/QIBM/UserData/OS400/DNS/_DYN/example.com.._KEY (symlink)
/QIBM/UserData/OS400/DNS/_DYN/Kexample.com.+005+48876.key
/QIBM/UserData/OS400/DNS/_DYN/Kexample.com.+005+48876.private

Le contenu du fichier de clé '/QIBM/UserData/OS400/DNS/_DYN/Kexample.com.+005+48876.key' peut ressembler à ceci : The contents of key file '/QIBM/UserData/OS400/DNS/_DYN/Kexample.com.+005+48876.key' might look like this:

example.com. IN DNSKEY 256 3 5
AwEAAaIANTvuE4hJyyJ+y+1wyH72dI8U7kvPxclzeDoApZDJkxixAoE/ KLvK8jxD
FdVzj6dP0UvC6RTVHOa05MYA7evs6UkRfbFHNobV+MvCVWN0w/1UoywYhi8MnvBK
akfv2x3SDiseSJs01Kl6jqg/UtSH41roJlzjuAiE /L3qHTCp

Messages d'erreur

Messages *ESCAPE *ESCAPE Messages

DNS0013
Erreur lors du traitement des paramètres de la commande. Error processing command parameters.
DNS0065
L'option 33 de i5/OS est requise mais n'est pas installée. Option 33 of i5/OS is required, but is not installed.
TCP7124
Le programme &1 de la bibliothèque &2, de type *PGM, s'est terminé anormalement. Program &1 in library &2 type *PGM ended abnormally.

© Copyright IBM Corp. Texte d'aide reproduit à des fins de formation.